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AAA 4.0 contains many enhancements and revisions to AAA version 3.7 as well as bug fixes
and enhancements to AAA version 3.7.

Section 1 shows the improvements and modifications made to AAA. Major enhancements
include new modules and calculations. Section 2 contains problem fixes.

The AAA Manual describes the installation procedure and all modules. The manual is available
in pdf format on the installation CD and download from www.darcorp.com.
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1. Enhancements and Modifications
Differences between AAA 4.0 and AAA 3.7 are:
1.1 Weight

1. The Forward-Aft C.G. plot X-axis scaling is now decoupled from the Total C.G. plot.
2. A warning pops up on the Total Aircraft Center of Gravity module when the C.G. is
forward or aft in the Flight Condition Definition dialog box, stating that the changes are
not retained in the Total Aircraft Center of Gravity module.
3. Landing gear weight is now dependent on the ratio of landing weight and take-off weight
instead of separate landing weight.
4. The landing gear C.G. is now in a table to allow the C.G. to be different for each gear
instead of only a total per category of gears.
5. Landing gear C.G.s are now flight condition dependent.
6. Engine weight can now be calculated per engine and is linked to the Class II Engine
Center of Gravity module.
7. Nacelle weight and BPR can now be entered for each engine.
8. Weight distribution is shown in the Class II>Moment of Inertia module.
9. Weight is assigned to the current weight if Forward or Aft C.G. is selected in the Flight
Condition Definition dialog box.
10. The Weight Regression module table is now expanded and allows for manufacturer and
reference input.
11. The number of spars in the inputs for the modules under the Component Inertia menu is
related to the input in the Structure Configuration dialog box.
12. The printout of the Airplane Inertia table has the right column width to incorporate all
characters.
13. The Radii of Gyration from Moment of Inertia module is now moved one level up.
Instead of Weight > Class I, it can now be found in Weight.
14. The user can change the recommended percentages of span and chordwise C.G.-location
of the wing.
15. A module to recalculate all component C.G.s has been added.
16. The power and thrust required for each flight segment is now calculated within the L/D
from Weights module.
17. Plotting the C.G. in the Class II: Total Aircraft Center of Gravity module shows the
empty weight C.G., current weight C.G., forward C.G. and aft C.G.
18. The C.G. of each engine is now calculated separately.
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19. The Class II Landing Gear Weight table now shows the weight for each individual gear
and if the module is cleared out, the Landing Gear Center of Gravity module has its
weights cleared.
20. The weight for each landing gear in the Landing Gear Center of Gravity module is now
separated instead of being lumped together by main and nose gear.
21. The number of shock struts for a certain gear is now an input in the Class II weight
Landing Gear table.
22. The air induction system weight is now calculated per inlet/nacelle.
23. When a landing gear is attached to a tailboom, a landing gear attachment factor is applied
to the Class II structure weight if not already defined by the user.
24. Final component weights are shown in the Take-off Iteration module.
25. A warning is in place for expendable payload to avoid including the expended payload in
the passenger or cargo weight.
26. The Cessna nacelle weight calculation is now calculated per engine.
27. The L/D from Weights module allows the input of the Class II drag polar polynomial
instead of only the Class I coefficients.
28. Inconsistency between Structure Weight modules and the Recalculate dialog box has
been solved.
29. The elevon is now added as a control surface in the Estimation of Wing Weight module.
30. Engine weight is split up per engine type in the Take-off Weight Iteration module.
31. Engine C.G. is now split up per engine type in the Class II Empty Weight table.
32. Engine weight is split up per engine type and per method in the Engine Weight
Estimation module.
33. Air induction weight is updated with a weighted average after the Weight Iteration table.
34. Take-off and empty weight are updated iteratively: initial weights will come from sizing
parameters, then will be updated in the Total Weight Iteration table.
35. DAR weight methods are now included in AAA.
36. Propeller weight is now distributed from the total weight across all propellers to better
capture C.G.-location.
37. Fuel system weight is divided out per fuel tank.
38. Each fuel tank has its own C.G.-location.
39. Propeller inertias are now included in AAA.
40. A Useful Load C.G. menu is now included in AAA, which allows user to specify location
and weights of all inputs under Payload/Crew and Fuel Tank modules.
41. Methods are now present for calculating inlet/duct weights when they are not contained
in a nacelle.
42. The “Total Weight” button has been renamed to “Aircraft Weight.”
43. The “Total C.G” button has been renamed to “Aircraft C.G.”
44. The Useful Load C.G. menu calculations are included in the Class II: total Aircraft
Center of Gravity module calculation.
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45. The Forward-Aft C.G. table is now constructed based on Fuel Tanks and Payload/Crew
dialog box selections.
46. Individual fuel tank C.G.s are now calculated in the Fuel Tank Center of Gravity module.
47. The option to keep the loading table from old files is now available. The new method
uses the Configuration dialog boxes to build the loading table.
48. Aircraft inertias have been split between empty weight and useful loads.
49. Inertia and C.G. calculations now check to see if a removable store is “on” or “off.”
50. Trapped fuel and oil has been removed from the Forward and Aft Center of Gravity
module and is now included in the Class II Empty Weight Center of Gravity module.
51. Loading conditions can be selected and viewed when Forward and Aft Center of Gravity
module entries number 12 or less.
52. Stores defined as fixed are counted as part of the aircraft empty weight and a warning is
displayed when stores are defined.
53. All body C.G.-location estimations are now calculated by a cross-sectional area
distribution based on user section inputs.

1.2 Aerodynamics

1. The Wing Alone Pitch Break Stability Boundary module is now under Aerodynamics
instead of Aerodynamics > Moment.
2. Tailbooms, stores and floats modules have been added under Aerodynamics > Moment.
3. A zero lift pitching moment contribution has been added for nacelles, tailbooms, floats
and stores.
4. An engine table is shown in the Subsonic Windmilling Drag Coefficient Prediction
module for a pure jet configuration.
5. An engine table is shown in the Subsonic Inlet Extra Drag module for a pure jet engine
configuration. Inlet drag is now calculated per engine.
6. The aerodynamic center is now plotted with C.G. location in the Aerodynamics >
Aerodynamic Center > Airplane module for top and side view.
7. Inputs for the linear and non-linear lift modules have changed for the horizontal tail,
canard and V-tail. These modules now require the lift coefficient due to control deflection
derivative at zero deflection instead of the balance factor and the change in airplane angle
of attack due to zero control surface deflection.
8. Drag-Build-up plot component selections are now stored.
9. The formula for the propeller inflow factor has changed from an approximation of 5.1.1-1
in NASA TN D-6800 to the original formula creating this figure.
10. The fuselage zero lift moment coefficient is also included in the multi-engine calculation;
it checks whether the fuselage is in the slipstream or not.
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11. The airplane minimum drag coefficient as well as the lift coefficient considering the
minimum are now calculated in the Class I Drag menu modules for the current flight
condition.
12. The linear term of the drag polars is now shown within all the Class I Drag menu
modules.
13. The aerodynamic center of the wing and fuselage now accounts for the downwash
gradient of the canard.
14. A new module called ‘Propeller Normal Force’ is included under the Propeller Power
Effects menu that calculates ∆CLN
.
prop

15. The CL − α module has been moved below the CL option of the Airplane Lift button.
16. The overall CLo now accounts for the downwash effect due to the canard.
17. CLα and CLα
now account for the downwash effect due to the canard.
clean
18. The points of the Class II drag polars are now plotted on the Class II drag polar trend
line.
19. The non-linear lift for the entire airplane and its components are now calculated and
plotted in a module together.
20. An Airfoil Definition button is now included and allows for entering and saving airfoil
aerodynamic data.
21. Users are now able to plot the A.C.-location and Class II C.G.s in the Airplane
Aerodynamic Center module.
is now calculated within the Calculation of Wing Maximum Lift module.
22. CLw
max

23. A legend has been added to the Non-Linear Lift plots that shows all the α and CLmax
values for all lifting surfaces.
24. The individual windmilling and stopped prop drag coefficients are shown for each
propeller.
25. The inlet diameter is now calculated based on inlet area in the Subsonic Inlet Extra Drag
module.
26. A Wind Tunnel: Drag Polars module has been made to determine drag polars based on
wind tunnel data.
27. The immersed area inputs for the landing gear are now separated by gear.
28. Drag Polar plots allow the CL axis to have values outside of the 0-10 range for the
minimum CL and 0-6 range for the maximum CL .
29. The A.C. of a lifting surface is set to 0.25 when it is outside of the regions where
interpolation of the graphs in Roskam Airplane Design Part VI is possible.
30. Class II drag modules for lifting surfaces show leading edge sweep and mean
aerodynamic chord as inputs.
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31. High Lift Device Sizing can now be done for multiple high lift devices including drooped
aileron. The high lift device to be sized can be selected and sized in the Lift > High Lift
Devices > Sizing module.
32. The individual CL contributions of the High Lift Devices are shown for take-off and
landing.
33. Ducted fans have been added to the Subsonic Inlet Extra Drag module.
34. Zero-lift drag and zero angle of attack drag are represented separately.
35. Canard downwash effect is included in the zero angle of attack lift coefficient, lift
coefficient gradient and zero angle of attack moment coefficient.
36. Class II drag for floats is now shown in a table to make it generic per float.
37. The Z-location for a slipstream has been incorporated for canard and wing.
38. The downwash from a canard on a wing is now shown as input in the wing linear lift
module.
39. Drag reduction due to winglets is now possible to model with pylon negative drag.
40. A Recalculate All option is added in the Power Effects menu.
41. Power effects were added to the maximum lift coefficient calculation.
42. The calculation method for propeller downwash/upwash constants has been changed
from graph interpolation to NASA formula.
43. Propeller downwash/upwash constants are now shown in a table output.

1.3 Performance

1. In the Performance > Analysis > Power/Thrust-Speed module, the minimum value for
plotting is now 0, instead of 0.01.
2. The balanced field length is no longer an output for single engine aircraft.
3. For the maximum cruise, maneuvering and climb sizing modules, the aspect ratio and
Oswald efficiency inputs have been replaced by a drag polar coefficient, BDP .
4. The maximum cruise speed allows selecting from all drag polars in the Flight Condition
Definition dialog box.
5. The ability to analyze performance of hybrid engine configurations has been added.
6. Airplane mean thrust at 0.707 lift-off-speed has been added to the Take-Off Distance
module calculations
7. A drag polar can now be selected for climb performance.
8. A drag polar can now be selected for cruise performance.
9. A drag polar can now be selected for endurance performance.
10. A drag polar can now be selected for payload range diagrams.
11. A drag polar can now be selected for maneuver performance.
12. A drag polar can now be selected for glide performance.
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13. A drag polar can now be selected for dive and descent performance.
14. Endurance unit options have been changed from min and seconds to hours and minutes.
15. The Landing Distance module allows for hybrid engine airplanes and gliders.
16. The Airplane Dive Performance module allows for hybrid engine airplanes.
17. The Maximum Cruise Speed module allows for hybrid engines; the T-V or P-V plot only
shows thrust for a hybrid configuration.
18. Propeller efficiency can now be defined in a table for each propeller defined in the
Propellers dialog box.
19. Total airplane propeller efficiency is now used for calculations.
20. Engine tables are present for performance calculations to make the module easier to use
for multi-engine configurations
21. The lift coefficient now calculated for maximum glide distance and time.
22. Sizing load factor is now a separate variable from flight condition load factor
23. In the time to climb calculation, an input for altitude at the beginning of the climb has
been added.
24. A plot has been removed from time to climb since it is already shown under climb
performance.

1.4 Geometry

1. Leading edge coordinates are calculated in the planform modules (Chord, Thickness,
Twist, Sweep button)
2. Ventral fin wetted area is now calculated.
3. A flap-aileron overlap check is implemented.
4. A label element is used to show whether all the high lift data is defined or not in the
Aileron/Elevon/Tab Geometry module.
5. The nacelle inlet area is now calculated within the Geometry module.
6. The total wetted area of the nacelles, stores, tailbooms, pylons, and floats is now
calculated within their respective module.
7. The wetted area for twin vertical tail configurations is now calculated per vertical tail
instead of as total vertical tail wetted area. In the airplane wetted area, this is accounted
for by multiplying the wetted area by two.
8. The pylon chords and span are now automatically imported from older files.
9. An Inlet/Duct Geometry module has been added.
10. Dorsal fin can now be exported to AeroPack as flat plate.
11. Hingeline locations are now allowed to be negative for hingelines in front of the moving
surface.
12. An updated wetted area calculation is used for bodies to allow for increased accuracy.
13. The Inlet/Duct Geometry module calculation will now output engine face area.
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14. The Inlet/Duct Geometry module calculation now outputs a duct integral for inlet
pressure loss calculation.
15. The control surface horn area is included in the output if a horn is present.
16. The control surface horn area/control surface area ratio is included in the output if a horn
is present.
17. The control surface horn span/control surface span ratio is included in the output if a horn
is present.
18. A warning is included for previous version files about control surface chord and area
calculation.
19. Double clicking an airfoil will select it.

1.5 Propulsion

1. The Thrust from Drag module allows use of the drag trend-line if this is selected in the
flight condition window.
2. Engines are now modeled per engine instead of all engines together.
3. Total power extraction can now be calculated for hybrid aircraft.
4. An engine table has been added to the Mechanical Power Extraction module.
5. An engine table has been added to the Electrical Power Extraction module.
6. An engine table has been added to the Pneumatic Power Extraction module.
7. An engine table has been added to the Class I Total Power Extraction module.
8. A table has been added to the Class I Inlet Area Sizing module that shows individual
engine areas and mass flow rates.
9. Engine type and operating condition are now shown in Mechanical and Pneumatic Power
Extraction modules.
10. The nozzle cross sectional area is now calculated on a per engine basis and is shown in
the engine table of the Jet Engine Parameters module.
11. A Propeller Interpolator module (Efficiency Charts button) has been added under the
Propeller heading that accepts .MAP files.
12. A new Installed Data button has been added under the Engine and Propeller headings.
13. An engine table has been added to the Class I Inlet Area Sizing module.
14. An engine table has been added to the Exhaust/Nozzle Exit Area module.
15. An engine table has been added to the Inlet Manifold Pressure module.
16. An engine table has been added to the Engine Installed Power and Thrust module.
17. The Inlet Pressure Loss module outputs are now separated by nacelle/inlet.
18. The inlet perimeter is calculated in the Inlet/Duct Geometry module.
19. Kloss is now calculated in propulsion > engine > installed data.
20. A module has been added for thrust forces and moments calculation.
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1.6 Stability and Control

1. Engine and Propeller tables are shown in the Take-off Rotation module and replace the
thrust vector variables (x, z coordinates of the origin and angle).
2. Propeller engine tilt angle is replaced by propeller incidence in the Take-off Rotation
module.
3. Airplanes with a pure jet configuration do not show the label ‘jet’ in the Engine table.
4. An additional row is added to the Propeller and Engine table in the Class II Trim
Diagram Analysis module to distinguish between input and output.
5. Asymmetric thrust in the Steady State Straight Line Flight Trim module is automatically
calculated on the engine operating condition.
6. A Propeller/Engine table is shown as an input for the Lateral-Directional Trim module in
the Class II Analysis menu to allow for asymmetric thrust.
7. A Propeller/Engine table is shown as an input for the Longitudinal Trim module.
8. CLδ is now an output for the Elevator Related Derivatives module ( CLδ button).
eo

e

9. CLδ
is now an output for the Ruddervator Related Derivatives module ( CLδ button).
rvo
rv
10. The Take-off Rotation module for flying wings calculates the elevon deflection.
11. The A.C. and C.G. are plotted in the Stick Free Static Margin module under the Analysis
heading.
12. Longitudinal trim canard parameters have been added to allow canard configurations and
3-surface airplanes to be modeled.
13. Canards are included in the Stick Free Static Margin module calculation for canard and
3-surface airplane configurations.
14. The Pitching Moment Trim: Thrust Calculated from Drag module supports 3-surface
aircraft with canard/horizontal tail with no control surface (canardvator/elevator) or
variable incidence.
15. Engine tilt angle is replaced by propeller incidence angle for propeller driven aircraft in
longitudinal trim and lateral-directional trim calculations.
16. Yawing moment due to engine inoperative is calculated automatically.
17. Pavail is used instead of Tavail for propeller aircraft in the Longitudinal Trim module.
18. Elevon effects are added to the sideforce, rolling moment, yawing moment and straight
line flight trim calculations.
19. Stick force is calculated for pure canards.
20. Elevons effects are added to the stickforce and aileron/elevon force calculations.
21. Elevons are added to the Lateral-Directional Control Derivatives modules
22. 3-surface airplanes now allow for multiple surfaces for longitudinal stick force
calculations.
23. Canard aircraft can now be trimmed longitudinally.
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24. Elevons can now be used for lateral-directional trim.
25. A wind tunnel scale has been integrated as an input where necessary in all modules
within the wind tunnel module.
26. The X ac for an elevon is now calculated within the Elevon Related Derivatives module
( Cmδ

el

button).

27. The stick-free neutral point for elevon trimmed aircraft is now calculated within the
Longitudinal Trim module.
28. An elevon can now be used as a trimming surface in the Longitudinal Trim module.
29. The CL limit for the aircraft maximum weight is now plotted on the trim diagram.
30. The Take-off Rotation module now considers the downwash of the canard on the wing.
31. The downwash gradient of the canard on the wing is now considered in the calculation of
Cmu .
limits for each
32. The trim diagram now shows the α ' limits rather than the α CL
max
component.
33. The constant deflection lines of the trim diagram no longer extend past the α ' limits.
34. The drag for windmilling or failed engines has been added as an input in the Longitudinal
and Lateral-Directional Trim modules.
35. An engine table has been added to the Lateral-Directional Trim module.
36. Asymmetric thrust is now calculated based on non-operating engines within the Straight
Line Flight Trim module.
37. The selection box within the Take-off Rotation module has been removed and the
calculations in that module are now dependent on the control surface selected in the
Flight Condition Definition dialog box.
38. The inoperative engine moment arm and its yaw factor are now calculated within the
Class I Analysis One Engine Out module.
39. The calculations in the Take-off Rotation module are now affected by the presence of an
elevon even if it is not the trim surface.
40. When a wind tunnel drag polar is selected, it will now show the wind tunnel drag table
label in Longitudinal Stability > Angle of Attack > CDα .
41. The propeller power setting can now be modified in trim calculations.
42. Setting an extremely negative flight path angle in the Trimmed Lift (T from D) module
now causes AAA to calculate the flight path angle to trim at zero thrust/power.
43. A stick force module (Stick Force button) has been added that takes speed as an input.
44. A Stick Force Trim module has been added.
45. A geared trim tab ratio input has been added to Stick Force Trim module. The gearing
ratio is entered as a polynomial.
46. Trim tab gearing is now included in the stick force module (Stick Force button)
calculations.
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47. A stick force per load factor gradient calculation has been added with tab gearing as an
input.
48. The steady state coefficients due to thrust now account for engine toe angle.
49. The pitching moment lift gradient due to propeller and jet thrust line now accounts for
engine toe angle.
50. Stick force calculations now allow for elevon, ruddervator and canardvator inputs.
51. The stick free neutral point now accounts for boost tab position.
52. The extra outputs for stick force gradients and stick static free margins in the
Longitudinal Trim module were removed and are now calculated in new windows.
53. A module has been added to calculate steady state pitch and yaw rates.
54. Yawing and pitching moment due to thrust as well as side force due to thrust for jets is
now calculated using inlet geometry.
55. Wing location analysis can now account for store, cargo, weapon and fuel tank C.G.
locations as well as user input items in the calculation.
56. Flying wing longitudinal control derivatives have been added.
57. Current speed and altitude have been added to the Trim Diagram plot legend.

1.7 Dynamics

1. When calculating the longitudinal flying qualities module, either the time-to-double the
amplitude or the time-to-halve the amplitude is calculated with the other becoming
invisible.
2. When calculating the lateral-directional flying qualities modules, either the time-todouble the amplitude or the time-to-halve the amplitude is calculated with the other
becoming invisible.

1.8 Loads

1. The Load Factors module now includes the Propeller table.

1.9 Structures

No Changes
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1.10 Cost

1. The Direct Operating Cost of Maintenance module has been made a function of each
individual engine.
2. The Cost Escalation factor has been updated to the 2018 year.

1.11 General

1. Under File>Export, there is now an option to export all defined parameters.
2. A warning will pop up when the landing gear is down and the aircraft speed is set to
transonic/supersonic in the Flight Condition Definition dialog box.
3. An export table button has been added to enable exporting just the table and therefore
making export/import tables more convenient.
4. If engines are set to non-operating, the available thrust is automatically set to zero.
5. In the Structure Configuration dialog box, the user can select a 3-spar structure.
6. The order of the C.G. calculation and the fwd-aft C.G. calculation in the Recalculate
dialog box has been reversed to allow AAA to determine which C.G.-location the
condition is associated with.
7. Wetted areas, component moments of inertia and moment of inertia have been included
in the Recalculate dialog box.
8. The “Copy WMF” dialog button has been renamed “Copy Window”.
9. Button sizes cannot be changed anymore.
10. Calculated variable notes can now be automatically assigned with a color.
11. A column has been added to each Nacelle table to show which engine the nacelle
corresponds to.
12. The engine can now be specified as either inside or outside of the fuselage.
13. The non-linear lift modules can now be recalculated by selecting Non-Linear Airfoil Lift
within the Recalculate dialog box.
14. The Lateral-Directional Trim module can now be recalculated by selecting Straight Line
Trim within the Recalculate dialog box.
15. In modules where the user has to switch between nacelles, the engine that is contained in
that specific nacelle is now displayed.
16. The output Go-to buttons are now invisible unless the user has been directed there
through an input Go-to button. It is only available for the variable pressed on the
previous screen.
17. The landing gear variables now have subscript “gear” instead of subscript “g”.
18. Maximum weight C.G. is now an option in the Flight Condition Definition dialog box.
19. Square brackets have been added around the units of the every plot axis.
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20. The Mach number or speed is shown in the Recalculation export when they are varied.
21. The speed in knots can now be varied in the Recalculation dialog box along with Mach
number.
22. The type of propeller and its operating condition are now shown in each Propeller table.
23. For each Landing Gear table, a column has been added with the number of the landing
gear. Another column has been added that has the landing gear type and whether it is in
the up, down or fixed position.
24. For the Propellers, Gears, Flaps, Engines, Nacelles and Stores dialog boxes, a ‘#’ heading
has been added above the number designation of a particular component.
25. The X-, Y-, and Z-coordinates along with the up or down condition of the landing gear
are now dependent on the flight condition.
26. Landing gear location can now be selected as a specific nacelle or tail boom within the
Landing Gears dialog Box.
27. If a ducted fan is a part of the configuration, but it is not associated with a nacelle, AAA
will show an error when the file is opened and whenever a module that deals with ducted
fans or nacelles is selected.
28. The user can now designate dorsal fins for a V-tail configuration.
29. When importing tables, the numbers are automatically rounded off to the proper number
of digits.
30. AAA can automatically put in notes for calculated variables.
31. AAA can automatically create notes for inputs containing user initials, date and a custom
note.
32. The Recalculate dialog box shows warnings and errors in the log window.
33. When a piston, turboprop or electric engine do not have a propeller attached, these
engines are not incorporated in the calculations for power/thrust.
34. Under File > Export, there is now an option to export all defined notes.
35. Under File > Export, there is now an option to export all locked variables
36. The Properties of the file now shows which AAA version it is saved in.
37. The right click dropdown menu allows users to lock a variable, to output a variable and
make the variable flight condition (in)dependent.
38. Table numerical entries are exported to a spreadsheet as numbers instead of text strings.
39. Air breathing engines are required to have an inlet.
40. An Inlet/Ducts dialog box has been added and inlet type has been moved from the
Engines dialog box to the Inlet/Ducts dialog box.
41. A lateral trim surface can now be selected in the Flight Condition Definition dialog box.
42. Nacelles, engines and propellers can be made tiltable in their respective dialog boxes,
which makes the geometric parameters for the nose coordinates of the body, incidence
and toe angle flight condition dependent. This allows for definition of VTOL aircraft.
43. A Resize button has replaced the Default button in plot windows.
44. The Windows wait cursor is now used during calculations to show the program is busy.

What’s New in AAA 4.0?

13

45. A Fuel Tanks dialog box has been added.
46. The engine miscellaneous loss factor is now calculated per engine.
47. An Unducted/Ducted Spinner option has been added to the Propellers dialog box.
48. A Pusher/Tractor option added to the Propellers dialog box.
49. A Payload/Crew dialog box has been added to replace all crew, passenger, cargo and
weapon inputs throughout the AAA modules.
50. The user is now able to specify the crew type in the Payload/Crew dialog box.
51. Moment & Stick Force Trim has been added to the Recalculate dialog box.
52. Plot Stick Force-Speed has been added to the Recalculate dialog box.
53. Altitude, take-off and landing distances have been changed to a unit of feet only.
54. The Exit button has been removed
55. The Configuration button order has been changed to match the required definition order.
56. Inlet tables now show if an inlet is associated with a nacelle.
57. An option has been added for different types of trim tab gearing.
58. Escape can now be used to stop an iteration in progress.
59. A warning has been added upon opening the Flight Condition Definition dialog box if the
center of gravity does not match the selected location.
60. The flight steady state condition has been removed from the Trim modules and added to
the Flight Condition Definition dialog box.
61. A warning now is created when the C.G.-location is changed in the Flight Condition
Definition dialog box to tell the user that the useful load C.G. will be chosen to match the
selected condition.
62. The empty weight moment of inertia calculation is now included in the Recalculate
dialog box.
63. The useful load C.G. calculation is now included in the Recalculate dialog box.
64. Stores can now be defined as removable or fixed. If fixed, they are not flight condition
dependent.
65. The Recalculate dialog box now calculates non-linear lift for all surfaces.
66. The lift calculation order has been changed so the maximum lift coefficient will be
calculated before the non-linear section.
67. Export to APP is now compatible with APP version 6.1.
68. Buttons and menus are now disabled while a dialog box is open to prevent the user from
causing an error when a dialog box is changed without giving AAA time to complete
operations.
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1.12 Other Improvements

AAA 4.0 airplane examples have been added and are available for download from
www.darcorp.com. More examples will be added over time, so keep visiting www.darcorp.com
for updates.
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2. Problem Fixes
This Section lists the problems found in AAA 3.7 and earlier versions, which are fixed in
AAA 4.0.

2.1 Weight

1. Electric routing length is now an output only.
2. The access violation produced while trying to plot the forward-aft C.G. location when not
all data is present has been resolved.
3. Torenbeek’s method for propulsion system weight no longer double accounts for jet
engines and turbofan engines in hybrid configuration airplanes.
4. The issue with negative wing inertia in the Wing Moment of Inertia module has been
resolved.
5. Propeller Data label is now properly updated in the Class II > Powerplant > Propulsion
System module when it initially is undefined and then the data is defined.
6. SHP is no longer an input for jet engines in the Weight > Class II > Powerplant >
Propulsion System module.
7. Forward and aft inertias have been removed in the Forward and Aft Center of Gravity
module since these variables are not used.
8. The C.G.s of electrical, hydraulic and flight control routing are now flight condition
dependent.
9. Wcurrent has been removed in the Forward and Aft Center of Gravity module if the C.G.location is forward or aft. It is still present if ‘Other’ is selected in the Flight Condition
Definition dialog box.
10. Clearing the outputs in the Take-off Weight Iteration module and then calculating no
longer results in a floating point error.
11. Air induction weight is no longer used in the Take-off Weight Iteration Module for
turboprops when the weight is already accounted for in nacelle weight.
12. The Ycg for the fuel volume was directly linked to a geometry module that considered a
wing half span instead of the full span. This issue has been resolved.
13. For fighter aircraft, the Vought engine starter system calculation in the Propulsion
System Weight Estimation module now uses thrust per engine instead of total thrust.
14. Nacelle weight is now allowed to be zero. The range is updated similar to the range given
in the warning.
15. Using a Go-to button in weight sizing and then closing a window no longer results in an
error about closed datasets.
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16. The Z-coordinate of the powerplant C.G. is now flight condition dependent.
17. Class II trapped fuel weight is now flight condition dependent.
18. For regression calculations, the minimum number of airplanes required is two in order to
prevent the floating point error in the weight calculation.
19. Payload weight is now allowed to be zero.
20. The Vought fuel system weight calculation for fighter aircraft no longer returns a zero
weight.
21. The Vought fuel system weight calculation now uses a volume unit of gallons instead of
cubic feet.
22. The total weight calculation now checks if an elevon input is present.
23. Cable routing control points no longer disappear when the plot axes range is changed.
24. FWrs now has a unit selector in the workpad.
w

25. The Class II fuselage weight Vought calculation is now only calculated when the
pressure differential is given.
26. If you change the C.G.-location in the inertia table, it will update in the empty weight
C.G. table.
27. The GD method has been enabled in the total weight table (weight iteration table) for
nacelles, fuel system and air induction.
28. Engines are now separated by type for hybrid configurations.
29. The total weight table now requires at least one Class II or user weight to improve
fidelity.
30. The X cg location for stores, tailbooms and floats is now dependent on incidence and toe
angle.
31. The Vought furnishing weight method for commercial aircraft now also includes baggage
weight instead of only cargo weight.
32. Hybrid propeller and jet aircraft now use the jet equation for range and loiter.
33. Payload weight is no longer accounted for twice in initial weight sizing.
34. A propeller definition is now required before entering the Weight Sizing modules.
35. The fuselage inertia calculation will now check the coordinate system definition.
36. A warning was added for pylon weight inclusion in the nacelle weight calculation.
37. Engine starter weight only applies to pneumatic starters and has been removed for all
other configurations.
38. Systems plot lines now move correctly when a plot is resized.
39. Stores that are turned off will now be excluded from C.G. calculations.

2.2 Aerodynamics

1. Class II drag for partially extended landing gears is now incorporated in the total drag
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2. The fuselage zero lift moment coefficient uses maximum fuselage diameter instead of
maximum fuselage diameter in the region of the wing.
3. While calculating Class II drag for an inlet, the equivalent friction coefficient is now
flight condition dependent.
4. The Class II drag for inlets now includes all inlets in the drag calculation. Previously it
was the drag for only one inlet.
5. Non-linear wing lift no longer shows an incorrect variable in the input.
6. L/D calculated in the Class II Drag menu is now flight condition dependent by default.
7. Users will receive an error when calculating Class II Airplane Drag for airplanes without
flaps.
8. The interference factor was not accounted for in Class II fixed gear drag resulting in a
dramatically high gear drag; the interference drag is now accounted for.
9. The non-linear C yv plot will now populate as long as C yv
> C yv * .
max clean
10. Control surface gap location is now flight condition dependent.
11. Class II fuselage base drag for buried jet engines is now calculated properly.
12. The ∆CLN
within the Lift due to Propeller Power Effects module is now calculated.
prop

13. The Subsonic Windmilling Drag Coefficient Prediction module now directs the user to
the Engines dialog box.
14. When the RPM of a non-operating engine is zero, the windmilling drag coefficient is now
zero.
15. The non-linear sideforce versus sideslip angle would not plot due to sign errors in the
checking process. Warnings now guide the user to adjust input signs as needed so that
the plotting can be correctly performed.
16. The vertical tail wetted area used in the CDo calculation is now just the wetted area of
one panel.
17. The Recalculate dialog box now calculates the exposed mean aerodynamic chord when
the wing span is smaller than the fuselage width.
18. Non-linear Lift and Sideforce plots have some more error checking to make them show
correctly.
19. Zero lift Class II drag now matches the trimmed trendline zero lift drag.
20. The C ftb symbol has been changed to C f store .
21. Lift calculation warnings have been added for the supersonic flow regime.
22. The number of allowable engines out and windmilling propellers increased to a
maximum of 500.
23. All Class I drag polars now show up on the All Polar plot.
24. If no lifting surface is defined, the number of high lift devices will automatically be set as
none, but the High Lift Devices dialog box can still be accessed.
25. The change in the dynamic pressure ratio due to power effects can now be negative.
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26. The Drag Polar plot axis will now take an input range for plot sizing.
27. Unused inputs for propeller downwash/upwash have been removed.
28. An incorrect warning for missing power effects data when an engine is off has been
fixed.
29. Store drag is no longer added to total drag when store is turned off.
30. Store drag calculation now recalculates Mach number as well to avoid errors when
changing the flight condition.
31. A check for table values in the Class II landing gear drag module has been added.
32. The interpolation for critical Mach for surfaces with a high lift coefficient has been fixed.
33. The error in the sweep translation formula for the lift curve slope in vertical tails and
pylons has been resolved.

2.3 Performance

1. The instantaneous level turn maneuver module no longer crashes when trying to plot.

2.4 Geometry

1. The vertical tail dihedral cannot equal +- 180 degrees, but it can be negative.
2. All dorsal fins are accounted for in wetted area calculations for configurations with more
than one vertical tail.
3. Pylons no longer show up as straight lines when importing older files.
4. The airplane 3-view no longer shows airplane parts outside of the axis.
5. AeroPack Export is no longer inconsistent with the toe angle and camber angle for
different bodies.
6. The inner fuel tank location has to be smaller than the outer fuel tank location to avoid
errors and negative fuel volumes.
7. The control surface horn balance outboard station is now allowed to be equal to control
surface outboard station.
8. The fuselage is now showing up in the airplane 3-view when the user opens older AAA
3.3 files.
9. The variable S plf s has been renamed to S plf store .
10. A plotting error where occasionally dimensions appear behind drawn lines has been
fixed.
11. A warning has been added for the 3-view plot if a dorsal fin is part of a configuration, but
is undefined.
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12. The cross-section drawing in the Airplane 3-View module has been corrected for body
incidence and toe angle.
13. A correction has been made to the shark export, which had incorrect rotation for spinners
and nacelles.
14. The repeated error for incomplete table information for all bodies has been removed.
15. The fuselage diameter at wing intersection calculation has been removed if there is no
wing.
16. The method for the body wetted area calculation has been revised to be more accurate.
17. Several airfoil coordinate files that were in the incorrect format and could not be loaded
by AAA were fixed.
18. Control surface area is now defined by the area aft of control surface hinge line.
19. Control surface mean geometric chord is now defined as the chord aft of the hinge line.
20. The aileron horn is now plotted when a elevon is defined as well.
21. The definition of control surface cord to lifting surface chord ratio was changed from the
MGC to the average chords to coincide with NACA definition.
22. Corrections were made to the control surface balance factor if control gap to chord ratio
is 0.

2.5 Propulsion

1. Jet Engine Parameter (X- and Z-location) for zero thrust is not calculated as it has no
physical meaning.
2. The file path name for propeller MAP files is now limited to 255 characters (before it
was 80).
3. The spinner factor could take a value between 0 and 1, where it could only be 0 or 1. This
variable is removed and replaced by a spinner column in the Propellers dialog box.
4. Extrapolation of inlet efficiency from the graph is done linearly right now to keep inlet
efficiency within bounds of 0 and 1.

2.6 Stability and Control

1. In Derivatives> Hingemoment> Trailing Edge Flap, AAA no longer asks for a wing tip
shape when the shape is already defined
2. Rotation speed is now used in take-off rotation calculations instead of U1 .
3. The input system for angle of attack longitudinal stability derivatives checks if nacelle
and pylon parameters are completely filled out.
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4. In the Recalculate dialog box, the downwash angle on the horizontal tail is now included
in the calculation routine.
5. The Longitudinal Trim module now only shows elevator/ruddervator variables when such
control surfaces are present.
6. The 3-surface aircraft trim ability has been fixed.
7. When there is an elevon and no aileron, the user is now able to enter the LateralDirectional Trim module.
8. An input for canards was added to the Stick Free Static Margin module so that it will
calculate when all inputs are present.
9. Cnrudder and Clrudder now change when you solely change the rudder deflection.
10. CLh is no longer in the inputs for the horizontal tail non-linear lift module.
α
11. When Class I drag was selected and there were no tabs present, the trimmed lift (T from
D) module would not converge.
12. When calculating vertical tail surface area while considering inherent stability, AAA will
no longer populate a negative surface area.
13. For 3-surface aircraft, the Longitudinal Trim module will now calculate all outputs.
14. The unit of xcg within the trim diagram now has the same units, i.e. percent or decimal,
when comparing the plot values and the output of the module.
15. An extra iteration would run in the trimmed lift (T from D) module after AAA said the
airplane was trimmed that would set the total aircraft power setting to zero.
16. When the wind tunnel drag polar is selected, it will now perform checks to see if the wind
tunnel drag polar is empty in the Longitudinal Stability > Angle of Attack > CDα module.
17. The control surface horn balance outboard station is allowed to be equal to control
surface outboard station.
18. The elevator deflection angle input Go-to has been disabled in Trimmed Lift Coefficients
(T=constant) module since it leads to the same module.
19. Straight line flight trim is now forced to have two control surfaces when entering the
module.
20. If a ducted fan is inside not in a nacelle, thrust pitching and yawing moment and side
force derivatives now have no effect.
21. The flight regime checking in trimmed lift (T from D) module was removed because of
possible error when the flight condition had the flight regime in its name.
22. The trimmed lift (T from D) calculation now checks for missing inputs.
23. Control pitching moment coefficients are now updated between iterations when trimming
an aircraft.
24. The variable name of the factor for downspring hingemoment due to incidence of V-tail
has been corrected.
25. A warning has been added for the Longitudinal Trim module if no elevator is defined.
26. Yawing moment due to thrust now accounts for incidence for increased accuracy.
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∂P
has been fixed.
∂V
28. Hingemoment will now calculate if the hingeline location is set to 100%.
29. Elevon Cmδ is no longer too large by a factor of two.

27. The unit for

el

2.7 Dynamics

1. In case there is no aileron/elevon/spoiler, the roll performance is no longer shown.

2.8 Loads

1. The V-n diagram variables C N max and VS now calculate if all inputs are present.

2.9 Structures

No Changes

2.10 Cost

1. The Airplane Production Line Life has to be greater than zero.

2.11 General

1. When a number is put in the workpad for a value inside a table, all decimals are stored
now.
2. The Data Not Defined label is updated when you define the data in the new module.
3. Font size has been increased in the Structure Configuration dialog box for several
options.
4. The cancel button in the Setup dialog box cancels changes in the radio buttons as well.
5. The Normally Aspirated option within the Engines dialog box is no longer misspelled.
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6. The Export All Values option within the Options menu can now be turned off.
7. When the column of a selected input has less decimal places specified than the input
variable, with the cell in question selected, the input will no longer be permanently
truncated to the specified number of decimals when Calculate is pressed.
8. A removed file used to be left behind after a Mach sweep calculation when excluding
some flight conditions. This issue has been resolved.
9. In the Recalculate dialog box, static margin, the error for V-tail configurations that the
vertical tail pressure ratio is missing has been removed.
10. When a table already contains data and table import is used, the data from the import file
overwrites the previous value and it does not change back to the old value when you click
on any cell.
11. Conversion for older files with nacelles does import the correct number of stations.
12. Aileron and elevon settings are copied from older files.
13. The horizontal tail would not show up in the airplane 3-view when importing older files
if not all of the parameters were defined correctly. This issue has been resolved.
14. When a nacelle table is still open, it no longer gives an access violation error when you
open up another module with a nacelle table.
15. When you try to update the range of any plot axis, it will update it to the number you put
in, instead of being rounded off.
16. Changing an input that has been rounded to the rounded number does change the number
now.
17. Axis window numbers do not update when pressing cancel.
18. The number of decimals in a table is not rounded of when you leave the AAA window
while the cell is being active.
19. Using the Recalculate dialog box when the engine operating condition is not set will no
longer pop up an error stating ‘’ is not a valid integer value.
20. Workpad can no longer be minimized; after being minimized, it would disappear after
minimizing and was only able to be recovered by double clicking the AAA icon in the
windows taskbar.
21. The workpad now shows the bar in ∆CD variables.
22. The moving flight conditions access violation was fixed.
23. File, Configuration, Certification and Setup buttons width were increased to fix text
overlap.
24. The number of definable bodies, such as stores and pylons, are now limited at 500.
25. A warning was added if propellers are not defined when importing old files.
26. Spin edit boxes for component amount definition no longer increase in size as number
increases past 100.
27. The overlapping text in table variable subscript was moved.
28. The table variables that overlapped table cell lines were moved.
29. A repeated warning when a previous work session is found was removed.
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30. The number of crew and passengers is now defined in the configuration setup and is used
consistently across all modules.
31. In the work pad, when cancel is clicked after checking Same Value for All Flight
Conditions, the selection will not be saved.
32. The variable description overlap in the workpad for variables with longer descriptions
was fixed.
33. Moving flight conditions through a large list will no longer display the list incorrectly
34. Values in the Flight Condition Definition Dialog box are saved upon entry so if a
new/edit/move/copy condition is selected, it will not revert to old values after change.
35. The Close window button is disabled during calculations.
36. The store flight condition dependence now checks the Stores dialog box.
37. A note color mix up using an old note color has been removed.
38. The flight condition center of gravity selection will now reset to the previous condition if
canceled after input.
39. The Copy Window tool now appropriately formats windows with large, scrollable tables.
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